Fixed Drivers Error with TP-LINK (TL-WN821N)

Discussion in 'Xiaopan Support' started by diogene, 18 Nov 2013.

  1. diogene

    diogene Member

    Joined:
    16 Nov 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Hello!
    When I use Xiaopan and do the process, for recognize my usb it's say to me "drivers error"!
    Have you got a solution?
    Thanks
     
  2. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    Joined:
    18 May 2012
    Messages:
    3,086
    Likes Received:
    1,186
    Trophy Points:
    351
    1. Well this isn't very helpful
    2. A screenshot will help
    3. Better descriptive title
    4. Steps to reproduce your error
    5. You posted in the wrong place
    6. We have a support forum
    7. What TP-Link is it?

    ‎a) TL-WN821N V1
    b) TL-WN821N V2
    ‎c) TL-WN821N V3
    d) TL-WN821N V4

    8. What version of Xiaopan are you using?
    :facepalm-10:
    Moving thread.....
     
    #2 Mr. Penguin, 18 Nov 2013
    Last edited: 18 Nov 2013
  3. diogene

    diogene Member

    Joined:
    16 Nov 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Okay,
    So I use VMware workstation 10.0 to use Xiaopan 2.4.7+ with a TL_WN821N V4!
    When I try to connect the TL after disconnect it from the host this message comes:
    "The connection for the USB device Realtek USB WLAN was unsuccessful. Driverf error."
    Have you got the driver?
    (Here the Screenshots!)
    Thank you very much for your help!
     

    Attached Files:

    • xio 2.jpg
      xio 2.jpg
      File size:
      101.3 KB
      Views:
      91
      MD5:
      906bbfbf85f5becb75b57260b941680c
    • xio 3.jpg
      xio 3.jpg
      File size:
      105 KB
      Views:
      74
      MD5:
      307409f937ad4ec889aaf220ef2d1729
    • xio4.jpg
      xio4.jpg
      File size:
      28.3 KB
      Views:
      77
      MD5:
      7062ea1745425058d7f219cec937470c
  4. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    Joined:
    18 May 2012
    Messages:
    3,086
    Likes Received:
    1,186
    Trophy Points:
    351
    You mean 0.4.7+? This is a problem with your host machine and your drivers on your host machine. Drivers used are rtl8192cu so it should work. Delete the drivers off your host machine or run it live. You should also try 0.4.7.2 or 0.5b2.
     
  5. diogene

    diogene Member

    Joined:
    16 Nov 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Thanks you'are very fast!
    So, I'm on 0.4.7.2 and delete the drivers of my host but still the message error (same!)
    Maybe I need to install the drivers rtl8192cu for linux?
     
  6. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    Joined:
    18 May 2012
    Messages:
    3,086
    Likes Received:
    1,186
    Trophy Points:
    351
    You are not understanding the issue. This is not something wrong with Xiaopan or Linux drivers. The error is inside the host machine and virtualbox. I suggest you run it live or use VMware.
     
Loading...
  • About Us

    We are a community mixed with professionals and beginners with an interest in wireless security, auditing and pentesting. Feel free to check out and upload resources.


    You can also find us on: Twitter and Facebook

  • Donate to Us

    Did you find our forums useful? Feel free to donate Bitcoin to us using the form below. Those who donate the equivlent of $10 USD or more will be upgraded to VIP membership. Don't have Bitcoin? Use your credit card to GO VIP here. Don't want to fork out some coin? There are other ways to GO VIP. Bitcoin: 1LMTGSoTyJWXuy2mQkHfgMzD7ez74x1Z8K