1. Hi Guest,

    $X9.99. Lowest price While stocks last. Be quick! OpenWRT compatible! Step 1: Visit Here

Fixed Dual Boot with Xiaopan & Windows XP

Discussion in 'Xiaopan Support' started by chensan, Oct 18, 2012.

  1. chensan Newbie

    What is the Issue?:
    1. Is there any way to dual boot xiaopanOS 0.4.3 with Windows 7 / XP ?​

    I tried to modify the method from Login or Signup to view links / downloads but is not working.​

    2. I tried to boot dual boot Beini 1.2.3 with Windows XP, it failed as it have the​
    Code:
    error pci_root PNP0A03:00: address space collision: host bridge window [mem 0x20000000-0x17ffffff] conflicts with PCI mem [mem 0x00000000-0xffffffff]

    ^As in the screenshot attached.​

    After i modify it the kernel to:​
    Code:
    quiet tinycore tce vga=792 waitusb=3 mydata=beini lang=en.utf8 restore=sda2/tce tce=sda2
    is successful​

    But, it is not detecting my USB AWUSO36NHR RTL8188RU, only internal Intel(R) PRO Wireless 3945ABG. Anyway to solve it?​

    Ultimately, What are you trying to achieve?:
    Hack WPA with a Dictionary attack with FeedingBottle

    What is your wireless device model?:
    AWUSO36NHR RTL8188RU

    USB or Internal Device?:
    USB

    How are you using it?:
    I am using Xiaopan in Parallels

    Operating System:
    Windows

    If you used a Live CD or USB How did you create it?:
    Unetbootin

    What version:
    Beini 1.2.3

    Attached Files:

    • DSCN1696.JPG
      DSCN1696.JPG
      File size:
      1.1 MB
      Views:
      142
      MD5:
      c360a262b445865932761fd8db27889c
  2. Mr. Penguin Administrator Staff Member Administrator Moderator VIP

    It says that you used Unetbootin? I suggest you use:
    Login or Signup to view links / downloads
    Login or Signup to view links / downloads

    As far as I am aware, making a duel boot with Beini / Xiaopan and Windows was possible. Would like to hear from anyone who was successful.

    Little confused with your post. It says you used unetbootin, parallels workstation and tried to make a duel boot as well.

    If you are editing the ISO you should only use UltraISO. I have tried with others and ended up with SQUASHFS errors.
  3. chensan Newbie

    Mr. Penguin, Sorry for confusing, this is the first time I'm requesting support here and thanks for your feedback. Wasn't it compulsory to choose a choice from the drop-down list ?

    Ultimately, What are you trying to achieve?:
    1. Trying to dual boot Xiaopan & Beini with Windows and of course with detectable USB RTL8188RU


    2. Successful USB Boot Xiaopan & Beini with detectable USB RTL8188RU

    What is your wireless device model?:
    AWUSO36NHR RTL8188RU

    USB or Internal Device?:
    USB

    How are you using it?:
    I am using Xiaopan / Beini from BIOS

    Operating System:
    Windows

    If you used a Live CD or USB How did you create it?:
    LinuxLive USB Creator

    What version:
    Xiaopan 0.4.3 /Beini 1.2.3

    Back to the questions above, i never success dual-booting xiaopanOS with Windows 7 / XP, only success dual-booting Beini with XP, and is with the error:
    Code:
    pci_root PNP0A03:00: address space collision: host bridge window [mem 0x20000000-0x17ffffff] conflicts with PCI mem [mem 0x00000000-0xffffffff]
    .

    I not sure what causing this error, currently using DELL Inspiron 1420 Intel Core 2 Duo 2.00GHz with DDR2 2GBx2 RAM, while changing it back to old DDR2 1GBx2 RAM will solve the issue.

    By following your advice, although i tried to boot using USB, where both Xiaopan and Beini was created using LinuxLive USB Creator, i wasn't able to detect the USB RTL8188RU, and worst situation for Beini where only able to detect until Core only. I got no issue with Backtrack DVD detecting my USB RTL8188RU.

    Additional Info:
    Booting XiaopanOS from VMWare is working correctly, but not able to detect USB RTL8188RU.
    Booting Beini from VMWare is working correctly without issue, able to detect USB RTL8188RU.

    Attached Files:

  4. jimpipe Active Member

    I have XP, BT3, BT4, Lupu525, Xiaopan 0.42, memtest86+, using GRUB4DOS 0.95 to boot up without problem!
    Tinycore prefer to boot on syslinux & isolinux than GRLDR!

    OK, to boot Xiaopan with GRUB you only need the correct lines in menu.lst to make it work:
    (In my case, I extracted XiaoPan_0.4.2.iso to C:\Xiaopan, you'll find 'boot', 'cde' folder & a xiaopanos.txt inside it.)

    Code:
    title XiaoPanOS 0.4.2
    find --set-root /xiaopan/boot/vmlinuz
    kernel /xiaopan/boot/vmlinuz quiet tinycore tce=sda1/xiaopan/cde/ tz=GMT+8 showapps vga=788 mydata=sda1/xiaopan lang=en.utf8 restore=sda1/xiaopan/cde
    initrd /xiaopan/boot/core.gz
    • Like Like x 3
  5. chensan Newbie

    Thanks jimpipe!

    I was finally able to boot it with Windows XP successfully using GRLDR method that you mentioned above, only when using Xiaopan OS 0.4.1, with detectable RTL8188RU.

    I'm still not able to detect the RTL8188RU while using Beini 1.2.3 / 1.2.4. I have no idea why is this happening.

    May I know which method do you think most likely / will work for booting with Windows 7? I have never tried the mentioned syslinux & isolinux method, i have tried with GRLDR but failed.
  6. jimpipe Active Member

    I presume Xiaopan OS is PnP OS, disconnect your wireless USB card before boot up then plug it in after it's fully boot to desktop.

    Open control panel -> system, look at the loaded module, find if your wireless card's module is loaded now.

    If the answer is yes, bring up the wireless interface from root shell:

    Code:
    ifconfig -a
    root# ifconfig rausb0 up
    root# ifconfig ath0 up
    root# ifconfig wlan0 up
    root# ifconfig wifi0 up
    ^Using trial & error to find the interface

    For example, 'ifconfig wlan0 up' did not shows any errors, the wireless card is using 'wlan0', check again by 'ifconfig' to confirm the device is listed.

    ^You may wish to put the device into monitor mode by 'iwconfig wlan0 mode monitor', or 'airmon-ng start wlan0' if the device is using madwifi-ng's drivers

    I'm not very familiar with Tinycore but majority distro's networks/devices setup/commands are quite similar.

    The dual boot Win7 / 2008 / Vista & Xiaopan is not simple as in Win XP but also possible with GRUB / GRUB2.

    The extra file needed is grldr.mbr and modified Windows's Boot manager to accomplish the task.

    GRLDR.MBR is the GRUB loader/manager's master boot record file, you can find it in the GRUB4DOS zip package.

    Put the 3 files, menu.lst, GRLDR & GRLDR.MBR in the root of the partition that contains 'XiaoPanOS', e.g. C:\

    WARNING
    BACKUP the BCD before proceed to modify any Win7/2008/Vista BOOTMGR. Any mistakes made in BCD may cause Windows fail to load.
    Make sure you have a bootable system recovery disc or USB ready standby.
    Open a Command prompt with Admin's previlege
    Code:
    [command to Backup BCD:] bcdedit /export C:\BCD\backupBCD.bcd
    [command to restore BCD:] bcdedit /import C:\BCD\backupBCD.bcd
    Code:
    [now add entry for GRUB4DOS to BOOTMGR:] [COLOR=#000000]bcdedit /create /d "GRUB Loader" /application bootsector[/COLOR]
    *32 digits HEX {UUID} is given for this new entry "GRUB Loader" in BOOTMGR, you'll need this UUID for all subsequence commands

    Code:
    bcdedit /set {UUID} device partition C:
    bcdedit /set {UUID} path \grldr.mbr
    bcdedit /displayorder {UUID} /addlast
    bcdedit /timeout 10
    bcdedit /v
    [Quit & closed Command Prompt:] exit
    *Those script lines in menu.lst are the same as dual boot XP/XiaoPan, except ones MUST CONSIDER: where is the C:\ partition reside?

    Here are the 3 typical scenarios
    Code:
    A - Recovery - sda1(hd0,0), SYSTEM - sda2(hd0,1), Windows[C:] - sda3(hd0,2)
    B - SYSTEM - sda1(hd0,0), Windows[C:] - sda2(hd0,1)
    C - Windows[C:] - sda1(hd0,0)
    Code:
    kernel /xiaopan/boot/vmlinuz quiet tinycore tce="sdaX"/xiaopan/cde/ tz=GMT+8 showapps vga=788 mydata="sdaX"/xiaopan lang=en.utf8 restore="sdaX"/xiaopan/cde
    Change the "sdaX" to match the partitions layout from above scenarios to yours.
  7. chensan Newbie

    Thanks again jimpipe! :joy I now able to easier dual boot Beini / XiaopanOS using EasyBCD 2.2 without using the command as above.

    Thanks for the guidance!

    For EasyBCD, what i required to do is "Add New Entry", press "Install" located in the tab "NeoGrub" of "Operating Systems".

    Once created, a new boot option will be created in the Boot Menu list where can be viewed in the "Edit Boot Menu" button.

    By using the provided NeoGrub of EasyBCD, i'll just required to copy the previous created menu.lst into C:\NST\ folder to replace the empty menu.lst of NeoGrub created by EasyBCD. And, thats it, is all done! ^^

    I tried to restart my PC, and able to choose the boot menu "NeoGrub Bootloader" which open up the menu.lst, where my Beini and XiaoPanOS can be found inside ;)

    my menu.lst will be just like below:- (Can be edited using Notepad)
    Code:
    default 0
    timeout 2
    title 1. Start Beini
    kernel (hd0,1)/Beini/boot/bzImage quiet tinycore tce=sda2/Beini/tce/ waitusb=3 showapps mydata=sda1/beini lang=en.utf8 restore=sda2/Beini/tce
    initrd (hd0,1)/Beini/boot/tinycore.gz
    title 2. Start XiaopanOS
    kernel /xiaopan/boot/vmlinuz quiet tinycore tce=sda2/xiaopan/cde/ tz=GMT+8 showapps vga=788 mydata=sda2/xiaopan lang=en.utf8 restore=sda2/xiaopan/cde
    initrd /xiaopan/boot/core.gz
    title 3. Reboot Computer
    reboot
    title 4. Halt Computer
    halt
    Geek
  8. jimpipe Active Member

    Glad to hear you have solved it.

    Yes, EasyBCD is a nice software to manage Windows Boot Manager especially Windows Vista/7/2008.
    No matter using what tools to edit Windows Boot Manager, ALWAYS backup the original BCD.
  9. chensan Newbie

    :yes Yes, the booting issue is solved, but weird is Beini is still not detecting the device. The 8188RU driver is loaded as in Control Panel > System, but i couldn't manage to locate the device from the list as in "sudo ifconfig -a".
  10. jimpipe Active Member

    I don't have Beini installed, is the same wireless card working in XiaoPan 0.43?
    If the answer is yes, then it is possible to replace the wireless drivers in Beini's folder with XiaoPan 0.43
    BTW, remove the 'waitusb' option in your menu.lst for Beini since you are booting from hdd and test again.

    Have fun...
  11. chensan Newbie

    yes correct, the same wireless card is working with XiaoPan 0.4.1, not working with XiaoPan 0.4.3 (this version might not compatible with RTL8188RU).
    The weird case is RTL8188RU is detectable in both Beini 1.2.4 / XiaoPan 0.4.1 while using VMWare, but not detectable in HDD Boot for Beini 1.2.4.
    How do I replace the driver in Beini folder? Do I just copy the driver files from XiaoPan to Beini's folder? It is as listed below (but the file type is different)?
    From Xiaopan\cde\optional
    Code:
    RTL8187L_ieee80211-3.0.21-tinycore.tcz
    RTL8188C_8192C_8192D-3.0.21-tinycore.tcz
    RTL8712_8188_8191SU-3.0.21-tinycore.tcz
    
    To Beini\tce
    Code:
    x_rtl8188ru_20110812.tce
  12. jimpipe Active Member

    Please refer to this thread: Login or Signup to view links / downloads
    According to Penguin, Beini 1.24 is based on Beini 1.23 and your card should be supported but maybe some conflicts with other drivers.
    The XiaoPan 0.4.2.3 may works for your card and Beini 1.23 is build for your card with conflict drivers deleted, read the change log inside Beini folder, *Beini 1.25 does not suit for your card!

    Xiaopan 0.42 detect my Linksys wusb54g and the module was loaded but can't work in inflator/feeding bootle/minidwep.
    In Xiaopan 0.43, it works flawlessly.
  13. chensan Newbie

    I got no issue when using Beini 1.2.3 / 1.2.4 in VMWare, both able to detect the RTL8188RU.
    And for XiaoPanOS, only version 0.4.1 able to detect it in VMWare, version 0.4.2 and 0.4.3 are not able to detect it.

    When come back to booting from HDD using Beini 1.2.3 / 1.2.4, both of them not detecting the device.
    And for XiaoPanOS, is the same as above, only version 0.4.1 able to detect it. Do you have any idea on this ?
  14. jimpipe Active Member

    Boot your XiaoPan or Beini without pluging in the wireless card, wait till it fully loaded to desktop and you can move the mouse freely, then plug in the wireless card! this trick may solve your problem.

    As the wierd problem for VM or virtualbox, my guess is VM running in Windows and those virtual pc are possibly using ndiswrapper to install the usb card.

    Core Linux is sometimes hard to troubleshoot even for experience linux user, I really appreciate the efforts for whom making Beini & Xiaopan for the community.
  15. chensan Newbie

    I had actually tried the mentioned method, by plugging in after everything is loaded, and i had tried it for another time, but the device just is not loaded, in Beini.
  16. jimpipe Active Member

    hi chensan,
    em...I think there is no point having 2 identical distro just to do the same job.

    Both Beini & Xiaopan offered almost same tools that what you all are after: feedingbottle/minidwep/inflator.

    The creator of Beini/Xiaopan may not have build all the wireless drivers in the firmware.tcz or the dependencies for it, maybe due to some drivers conflict reported by end user...or whatever reasons. (Read the changed logs for the respective build)

    As for your wireless card, you can always blacklist other wireless card drivers except yours.
  17. chensan Newbie

    how to blacklist other wireless card drivers?
  18. jimpipe Active Member

    When Tinycore boot up, it will 1st need to know where is it extension files and any backup/restore/customized file located, then it will load applications/drivers which listed in onboot.lst and copy2fs.lst into RAM, mydata.tgz (default backup files) or xiaopan.tgz (cuztomized backup file by xiaopan) which contained any special settings will restore to the system structure.

    Both 'APP/Driver'.tce and 'APP/Driver'.tcz are installable Tinycore Extension file.
    '.tce' will get priority install to RAM and ready at any time, '.tcz' doesn't occupied in RAM deliberately unless specified in onboot.lst or copy2fs.lst.

    Tinycore will search inside the 'tce' folder you've specified in the boot parameter, for onboot.lst, mydata.tgz, also 'optional' and 'ondemand' folders. All priority loaded Tinycore extensions files should put inside 'optional' folder, and those not acitively run should put inside 'ondemand' folder. The idea is to lighten the load of RAM in use.

    To blacklist all other wireless drivers, move them into the 'ondemand' folder. Edit the onboot.lst and load only your wireless driver.

    Some corrections to your menu.lst:
    color cyan/blue white/blue
    timeout=10
    default=0

    #Testing OK
    title Beini 1.24
    find --set-root (hd0,1)/Beini/boot/bzImage
    kernel /Beini/boot/bzImage quiet tce=sda2/Beini/tce mydata=mydata lang=en.utf8 showapps vga=788
    initrd /Beini/boot/tinycore.gz

    #Tested OK
    title xiaopanOS 0.4.2.3
    find --set-root (hd0,1)/xiaopan/boot/vmlinuz
    kernel /xiaopan/boot/vmlinuz quiet tce=sda2/xiaopan/cde mydata=xiaopan lang=en.utf8 showapps vga=788
    initrd /xiaopan042/boot/core.gz

    *NOTE:
    1. The Backup/Restore doesn't work for NTFS, you'll get error when trying WRITE to it.
    2. mydata=filename without the .tgz extension
    --- Double Post Merged, Nov 3, 2012 ---
    You may find some useful commands here for all you need:
    Login or Signup to view links / downloads

    You'll too find many useful info regarding Xiaopan & Beini.

    Have fun...
  19. chensan Newbie

    Thanks jimpipe for the additional info.
    Both of these line don't seems to work
    The Error is :
    Code:
    Error 42: The leading DEVICE of the filenamee to find must be stripped off, and DIR for set-root must begin in a slash(/).
    Other line is working perfectly. :)
  20. jimpipe Active Member

    Hi, please forgive my mistake on post #4 regarding "using GRUB4DOS 0.95 to boot up without problem!", it should be GNU GRUB 0.95!! and it works but not for Grub4Dos 0.4.x

    I've messed up with many different version of GRUB loader -_-''

    Below is the 'Grub4Dos 0.4.5c' menu.lst I'm currently using (OS is Windows XP):

    #Grub4Dos 0.4.5c
    #menu.lst
    #
    color white/blue black/light-gray white/black white/black
    timeout=30
    default=0

    #Tested OK
    title Boot from Hard Disk
    root (hd0,0)
    chainloader +1

    #Tested OK both GNU Grub 0.95 & Grub4Dos 0.4.5c
    title BackTrack 3 Final
    find --set-root /GRLDR
    kernel /boot/vmlinuz3 vga=0x317 ramdisk_size=6666 root=/dev/ram0 rw
    initrd /boot/initrd3.gz

    #Tested OK for GNU Grub 0.95, fail Grub4Dos
    #title xiaopanOS 0.4.2.3
    #find --set-root (hd0,0)/xiaopan042/boot/vmlinuz
    #kernel /xiaopan042/boot/vmlinuz quiet tce=sda1/xiaopan042/cde lang=en.utf8 showapps vga=788
    #initrd /xiaopan042/boot/core.gz

    #xiaopan.tgz doesn't work for 0.4.2.3, wrong contents
    #mydata=xxx, restore=xxx doesn't work in NTFS, work fine in FAT/16/32

    #Tested OK for Grub4Dos 0.4.5c
    title xiaopanOS 0.4.2.3
    find --set-root /xiaopan042/boot/vmlinuz
    kernel /xiaopan042/boot/vmlinuz quiet tce=sda1/xiaopan042/cde lang=en.utf8 showapps vga=788
    initrd /xiaopan042/boot/core.gz

    #Tested OK for Grub4Dos 0.4.5c
    title XiaoPanOS 0.4.3b
    find --set-root /xiaopan043/boot/vmlinuz
    kernel /xiaopan043/boot/vmlinuz quiet tce=sda1/xiaopan043/cde lang=en.utf8 showapps vga=788
    initrd /xiaopan043/boot/core.gz

    # For booting SliTaz from sda1 for Grub4Dos 0.4.5c
    title SliTaz GNU/Linux (Cooking)
    find --set-root /slitaz/bzImage
    kernel /slitaz/vmlinuz-2.6.30.6-slitaz root=/dev/sda1/slitaz/ vga=normal
    initrd /slitaz/rootfs.gz

    #Tested Beini 1.24 - 30102012 for Grub4Dos 0.4.5c
    title Beini 1.24
    find --set-root /beini124/boot/bzImage
    kernel /beini124/boot/bzImage quiet tce=sda1/beini124/tce mydata=mydata norestore showapps vga=788 lang=en.utf8
    initrd /beini124/boot/tinycore.gz

    #Tested Beini 1.25 - 30102012 for Grub4Dos 0.4.5c
    title Beini 1.25
    find --set-root /beini125/boot/bzImage
    kernel /beini125/boot/bzImage quiet tce=sda1/beini125/tce mydata=mydata norestore showapps vga=788 lang=en.utf8
    initrd /beini125/boot/tinycore.gz

    #Tested CorePlus 4.6.2 with aircrack-ng + reaver for Grub4Dos 0.4.5c
    title CorePlus 4.6.2 with aircrack-ng
    find --set-root /CorePlus462/boot/vmlinuz
    kernel /CorePlus462/boot/vmlinuz quiet tce=sda1/CorePlus462/cde norestore showapps vga=788 lang=en.utf8
    initrd /CorePlus462/boot/core.gz

    #Tested both OK for Grub4Dos 0.4.5c & GNU GRUB 0.95
    title Lucid Puppy Linux 5.2.8 stable
    kernel (hd0,0)/lupu528/vmlinuz pmedia=satahd pdev1=sda1 psubdir=lupu528 video=800x600
    initrd (hd0,0)/lupu528/initrd.gz

    #Tested both OK for Grub4Dos 0.4.5c & GNU GRUB 0.95
    title Macpup 5.2.9
    kernel (hd0,0)/MacPup529/vmlinuz pmedia=satahd pdev1=sda1 psubdir=MacPup529 video=800x600
    initrd (hd0,0)/MacPup529/initrd.gz

    #Tested with GRUB4DOS OK, fail GNU GRUB
    title Win7x64 PE - contiguous image contiguous-boot OK
    map /Make_PE3/win7pe_amd64/7pe_amd64_E.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)

    #Tested with GRUB4DOS OK, fail GNU GRUB
    title Win7x64 PE - contiguous image contiguous-boot OK
    map /Make_PE3/win7pe_amd64/7pe_amd64_E.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)

    #TEST OK
    #title Test 7pe_amd64_E.iso - contiguous ISO - OK fast
    #find --set-root --ignore-floppies /Make_PE3/win7pe_amd64/7pe_amd64_E.iso
    #map /Make_PE3/win7pe_amd64/7pe_amd64_E.iso (0xff)
    #map --hook
    #root (0xff)
    #chainloader (0xff)/BOOTMGR
    #
    #Test OK
    #title Win7x64 PE Multiboot Grub - non-contiguous image virtual-boot
    #map --mem (hd0,0)/Make_PE3/MULTI_ISO/MULTI-11-11-2012.iso (0xff)
    #map --hook
    #root (0xff)
    #chainloader (0xff)
    #boot
    #
    #TEST OK Windows defender offline x86/x64
    #title WDO_Media32.iso - contiguous ISO
    #find --set-root --ignore-floppies /boot/WDO_Media32.iso
    #map /boot/WDO_Media32.iso (0xff)
    #map --hook
    #root (0xff)
    #chainloader (0xff)+1

    #Test OK with GRUB4DOS loader, fail GNU GRUB
    title boot WXPE2005
    find --set-root /boot/WXPE.iso
    map /boot/WXPE.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)

    #Test OK
    title Boot Win98sud.ima
    map /boot/w98sud.ima (fd0)
    map --hook
    chainloader (fd0)+1
    rootnoverify (fd0)

    #Test OK
    #title [TEST] boot W98sud.ima.gz - virtual
    #map --mem /boot/w98sud.ima.gz (fd0)
    #map --hook
    #root (fd0)
    #chainloader (fd0)+1

    #Tested OK
    title Memory Test - memtest86+ 2.11
    find --set-root /GRLDR
    kernel /boot/memtest.BIN

    #OK tested
    title Reboot Computer
    reboot

    #OK tested
    title Shutdown Computer
    halt

    #########Boot LIVE ISO##############
    #
    #
    #TEST OK
    title slitaz-4.0.iso - contiguous LIVE ISO
    find --set-root --ignore-floppies /boot/slitaz-4.0.iso
    map /boot/slitaz-4.0.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    #
    #TEST OK
    title slitaz aircrack-ng - contiguous LIVE ISO
    find --set-root --ignore-floppies /boot/slitaz-aircrack-ng.iso
    map /boot/slitaz-aircrack-ng.iso (0xff)
    map --hook
    root (0xff)
    chainloader (0xff)
    #
    #
    --- Double Post Merged, Nov 19, 2012 ---
    Thank you Mr. Penguin:) and where to post tutorial or info to help others?
    • Winner Winner x 1