1. AWESOME DEALS. Get an AWUS036H for $15.00 US including delivery (only US) or Reaver Pro II for $74.99 Free Delivery WorldWide. CLICK HERE

     

Fixed How to Run Beini in VMware with Atheros AR 928X Internal Card

Discussion in 'Xiaopan Support' started by helen, Aug 2, 2012.

  1. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    I use Windows XP Pro on a notebook Toshiba A300 1GC that haw an Atheros AR 928X Wireless Network adapter.

    I tried to use Beini (as well as xiaopan-0.4.1.iso)
    schedaretemiopc.jpg

    There are many videos on how to work with Beini in VMware Player and this is the help I amm asking you.

    It can not detect anything why? Maybe, I'm quite sure, I make some mistakes but...who can help me step by step so that i will be able to understand where my mistake is (or maybe somebody has a link to share a better video tutorial.

    Thank's in advance!
    Grazie!
    Danke!
    Take Care
    Helen
     
    #1
  2. Pascal

    Pascal Wifi Sniffer Staff Member Moderator VIP

    Joined:
    Jun 6, 2012
    Messages:
    201
    Likes Received:
    86
    Hello Helen ;)

    Welcome on the forum ;)

    VMware can not use the internal card!

    He can use it as a relay but that's all. You need an external USB card or install production that you want to dual boot. ;)
     
    #2
    • Like Like x 1
    • Agree Agree x 1
  3. Mr. Penguin

    Mr. Penguin Administrator Staff Member Administrator Moderator VIP

    Joined:
    May 18, 2012
    Messages:
    2,829
    Likes Received:
    1,041
    #3
  4. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    Thank you for all the replies. I'm "just back" from a few boots of Beini (with this notebook it is easy to boot just by pressing F12. But. No luck at all! I get many errors loading, just for one example Beini-1.2.5_DishingTech.iso but after may errors I get a screen without any programs. So i don't what to was your time let we see if you can help by giving me an easy solution. I have a USB pen wifi which I can use on a VMware with a (ZD1211B IEEE 802 b+g) all under Windows XP. But after that how i can run Beini? I cant run two virtual machines so, have u got any solution / help?
     
    #4
  5. Mr. Penguin

    Mr. Penguin Administrator Staff Member Administrator Moderator VIP

    Joined:
    May 18, 2012
    Messages:
    2,829
    Likes Received:
    1,041
    Use Xiaopan 0.4.1
     
    #5
  6. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    Ok i got it. I have a Windows XP Pro on the VMware and i have installed the drivers of the wifi pen. What must I do to run Xiaopan 0.4.1?

    I have olso tried that version of Xiaopan before useing a DVD-W that I have but if i remember I can't load the screen (i tried user: xiaopan password: xiaopan but no luck so, with the VMware how can I start the program?
     
    #6
  7. Fantasma

    Fantasma Well-Known Member

    Joined:
    May 31, 2012
    Messages:
    745
    Likes Received:
    417
    I guess i can help you since i have the same card you have, just Follow this steps to boot from your pendrive:
    (Xiaopan OS don't ask for password at start)

    1.- Download Login or Signup to view links / downloads (If you have the iso already, jump to next step)
    2.- Format your pendrive as fat32 (not quick format)
    3.- Follow this: Login or Signup to view links / downloads
    4.- Reboot your notebook and select boot from your USB
    5.- Happy Pentest !
    p.s Your Ar928x card will work great, I'm not sure if your USB wifi card will work properly since it has a very old chipset but you can try anyway
     
    #7
  8. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    I will copy everything and i will do exactly what you wrote and I will tell u tomorrow the results.

    Yes my wifi en is ok do u know why?

    Why by this moment i'm running beini 1.2.2 ISO under VMware where I have the pen connected.

    What i cant understand why is getting so difficult to get the wpa key of my router infact the signal ios string, the router is quite close to me as you see in the pictures:

    Why is that? Otherwise i wil go tomorrow I will give you results.
     

    Attached Files:

    #8
  9. Fantasma

    Fantasma Well-Known Member

    Joined:
    May 31, 2012
    Messages:
    745
    Likes Received:
    417
    Seems you're trying crack a WPA key with feedingbottle, do you got an handshake? once you get the hand shake you need use a good dictionary to test passwords, it can take hours, days or maybe and probably never!

    if your network has WPS enabled you can use Reaver on minidwep / reaver pro (not recommended so much, but you can try) for WPA keys
     
    #9
  10. Mr. Penguin

    Mr. Penguin Administrator Staff Member Administrator Moderator VIP

    Joined:
    May 18, 2012
    Messages:
    2,829
    Likes Received:
    1,041
    You can speed this up authenticating and deauthenticating the AP with the advanced settings. I noticed it is WPA-PSK, strong chance Inflator will give you the results you are after :)
     
    #10
  11. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    So at the end the "work" is very long and is not so fast as it seems to be? About creating a bootable USB I have a few problems:

    1. When I select the xiaopan-0.4.1 minidwep-gtk 30419.iso in the Lili USB creator the program tell me that the program dosen't support that version of Linux.

    2. I keep all settings as èpic but I need to install sandbox?

    Otherwise for three times nearly at the end of the setup of the usb pen my wifi connection drops down (and the program try to send me to a web site) i have tried to boot my notebook to usb but nothing it will not boot i mean when i select usb doesn't happend anything and i'm always on the screen where to choose HDD CD except maybe because when wifi connection drops down will stop to install everything in the usb pen and then everything is corrupted?
     
    #11
  12. Mr. Penguin

    Mr. Penguin Administrator Staff Member Administrator Moderator VIP

    Joined:
    May 18, 2012
    Messages:
    2,829
    Likes Received:
    1,041
    :? Please Read the Forum rules
    :? Also can you please be more careful with your spelling

    I realise you are from a non English speaking country but there were some really careless errors e.g: "Lil us creator". Makes it hard to help you.

    I have fixed your posts up and it took forever. Thank you.
     
    #12
  13. Fantasma

    Fantasma Well-Known Member

    Joined:
    May 31, 2012
    Messages:
    745
    Likes Received:
    417
    See what the program say when you select the Xiaopan iso, this version of linux is not... blah blah ...but will try with default... blah,blah
    at the end of installation process it open the LiLi web site to show you how to use your Live USB, if you stop the Installation process of course it won't boot.


    Keep the default options checked and no, you don't need install VirtualBox. just let the program work from start to end and all will be ok, you will be able to boot from your pendrive
     
    #13
  14. helen

    helen Active Member

    Joined:
    Aug 2, 2012
    Messages:
    17
    Likes Received:
    2
    ok nessun problema vedrò di stare più attenta l prossima volta! ok i will try to be more careful next time

    Helen
    --- Double Post Merged, Aug 2, 2012 ---

    PS:Ok this time is all ok i done the bootable usb pen without installing the virtualbox and selecting to see the files that the program will install on the pen,later i will restart my notebook and test everything.
    Just a last question maybe as you know the program can create the usb pen bootable installing virtualbox have you ever test that way? I try to explain myself better.

    Have u never tried to start the usb pen under windows nd when u was testing your lan you was also doing other things on computer? If that way works will be great! Without keeping the computer "locked" for not know how much time working only under Xiaopan.
     
    #14