Fixed Reaver Pro Won't Detect RTL8187

Discussion in 'Xiaopan Support' started by easy1, 10 Oct 2012.

  1. easy1

    easy1 Member

    Joined:
    8 Oct 2012
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    18
    I have downloaded the Reaver Pro and detect RTL8187 wireless card, it detects wifi's but it shows WNL0 (RTL8187) disabled and i search every where in reaver pro to enable it and their is no option, i have try to "start" but i gets nothing, i have done it Parallets desktop, VM and IS0 Usb with my windows laptop and Mac desktop and i get the same problem, can any one give an advise on how to resolve this issue, oh it works well with XiaoPan 0.4.2.3 and it works well with Feeding bottle and minidwep with my iMac or Windos
     
  2. Pascal

    Pascal Wifi Sniffer
    Staff Member Moderator VIP

    Joined:
    6 Jun 2012
    Messages:
    211
    Likes Received:
    89
    Trophy Points:
    256
    Connect your USB Card when you boot ReaverPro if not, when reaver start, alt + F8 and up your card in monitor mod ;)
     
  3. easy1

    easy1 Member

    Joined:
    8 Oct 2012
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    18
    i have done that on my parralets desktop and my parralets detects its but reaver pro won't
     
  4. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    Joined:
    18 May 2012
    Messages:
    3,085
    Likes Received:
    1,186
    Trophy Points:
    351
  5. Pascal

    Pascal Wifi Sniffer
    Staff Member Moderator VIP

    Joined:
    6 Jun 2012
    Messages:
    211
    Likes Received:
    89
    Trophy Points:
    256
    when reaver Pro work :

    ALT+F8


    And in a terminal start your card in monitor mod !!!
     
    • Like Like x 1
  6. easy1

    easy1 Member

    Joined:
    8 Oct 2012
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    18
    i tried it live and install from parralets and ALT+F8, Pascal, I ran the terminal and tried start my card monitor mode, I did "su tech" and then i entered the password and then i entered this command "airmon-ng start wlan0" and it said that i should start in root and it gave me this command "tech@reaver:/home/reaver$" and it keeps repeating over and over every time i try entering mointor mode command
     
  7. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    Joined:
    18 May 2012
    Messages:
    3,085
    Likes Received:
    1,186
    Trophy Points:
    351
    Try the following:
    Code:
    Select All
    sudo airmon-ng start wlan0
    If this does not solve your problem, please upload screenshots or embed a video as it will help explain your issue better.
     
    • Like Like x 1
  8. easy1

    easy1 Member

    Joined:
    8 Oct 2012
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    18
    thanks pascal and mr penguin for the help, mr penguin i figure that out and yes it was sudo that i was missing in the command it is working but its taking a long time to ping
     
    • Like Like x 1
  9. fina

    fina Active Member

    Joined:
    9 Oct 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    31
    i have same problem with wifi i press alt+F8 does not work please tell me what to do ?
     
  10. Melroy Rodrigues

    Joined:
    13 Sep 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    6
    I am also having the same problem , it is comming as wireless adapter not ready
     
  11. Pascal

    Pascal Wifi Sniffer
    Staff Member Moderator VIP

    Joined:
    6 Jun 2012
    Messages:
    211
    Likes Received:
    89
    Trophy Points:
    256
    Thank you to read about the whole forum!


    If your card is not detected, thank you to specify your configuration and the way you run this or production.
     
  12. kokopunjisar

    kokopunjisar Member

    Joined:
    29 Sep 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    6
    mine i am using signal king 10tn.. i install the reaver in my pendrive and boot it..is starts...and there were the play button with will comand to search for network..when i click it..nothing happens..since there are 5 networks on...i gues my adapter is not detected..pls help me sir.
     
  13. Surendra Karwasra

    Joined:
    16 Apr 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    6
    Reaver pro didn't detect my usb wifi. my card is TL-WN821N.
     
  14. MegaVlad

    MegaVlad Active Member

    Joined:
    27 Aug 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    31
    Xiaopan can't detect my wireless card. How can i add drivers?
     
Loading...
  • About Us

    We are a community mixed with professionals and beginners with an interest in wireless security, auditing and pentesting. Feel free to check out and upload resources.


    You can also find us on: Twitter and Facebook

  • Donate to Us

    Did you find our forums useful? Feel free to donate Bitcoin to us using the form below. Those who donate the equivlent of $10 USD or more will be upgraded to VIP membership. Don't have Bitcoin? Use your credit card to GO VIP here. Don't want to fork out some coin? There are other ways to GO VIP. Bitcoin: 1LMTGSoTyJWXuy2mQkHfgMzD7ez74x1Z8K