Enable NTFS Write for Mountain Lion

Discussion in 'Resources' started by Mr. Penguin, 16 Jun 2013.

  1. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member VIP Admin

    18 May 2012
    Likes Received:
    Ok, Macs can mount NTFS drives but they can not be written on without enabling it by default. This is problematic if you have a external hard drive with all your media and you can't store downloads, music or pictures on it. We can format it to Mac OS X Journaled but that breaks compatibility with Windows. From 10.8.3 onwards Mac OS X can enable write permissions but you have to enable it.

    The first thing you should do is delete any 3rd Party NTFS software such as OSXFuse, Paragon NTFS for Mac, Tuxera or NTFS-3G.

    Open up terminal and type
    Select All
    sudo vi /etc/fstab
    Now, if you get anything like the following
    Select All
    E325: ATTENTION Found a swap file by the name "/etc/.fstab.swp" owned by: root dated: Sun Jun 9 22:05:35 2013 file name: /private/etc/fstab modified: YES user name: root host name: localhost process ID: 3930 While opening file "/etc/fstab" dated: Sun Jun 16 02:18:13 2013 NEWER than swap file! (1) Another program may be editing the same file. If this is the case, be careful not to end up with two different instances of the same file when making changes. Quit, or continue with caution. (2) An edit session for this file crashed. If this is the case, use ":recover" or "vim -r /etc/fstab" to recover the changes (see ":help recovery"). If you did this already, delete the swap file "/etc/.fstab.swp" to avoid this message. Swap file "/etc/.fstab.swp" already exists! [O]pen Read-Only, (E)dit anyway, (R)ecover, (D)elete it, (Q)uit, (A)bort:
    • Just click E for Edit anyway
    • Click i and add to the first line
    Select All
    LABEL=”VOLUME_NAME_WITHOUT_QUOTES” none ntfs rw,auto,nobrowse
    • If you are not sure of the drive name use Disk Utility and if there is a space between a drive name like MEDIA DRIVE be sure to put the underscore like MEDIA_DRIVE
    • After you are done click Esc and type :wq (Thanks TCB13)
    • Now unmount and remount your drive using Disk Utility so changes can take effect
    • You will not be able to see your NTFS drives in Finder, the Finder sidebar or on your desktop you will have to type the following:
    Select All
    open /Volumes/THE_NAME_OF_YOUR_VOLUME
    This would not have been possible if it wasn't for this blog by Prateek Joshi: http://prateekvjoshi.wordpress.com/2013/04/21/ntfs-write-support-on-os-x-mountain-lion/ Thank you :)

    Now, I had an issue upgrading from 10.8.0 to 10.8.4 where my NTFS drives were not mounting with my hackintosh. Console produced the following error codes

    Select All
    DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.
    Select All
    failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
    Select All
    LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
    Select All
    /Library/Filesystems/fusefs.fs/Support/fusefs.kext failed to load -(libkern/kext) link error; check the system kernel logs for errors or try kextutil(8). the MacFuse file system is not available(71) _nfts_volume_release(): Inode 9 still have 1 references."
    • All I did was boot into Windows through Chameleon and disabled fast boot from the energy settings in Windows 8
    • Then I restarted into Mac OS X and typed the following in Terminal:
    Select All
    sudo nvram boot-args=
    • and rebooted
    Your drives should be there now :)

    If you are still having issues
    • Make sure all the files and preference panes are deleted for 3rd party NTFS software.
    • Clear your system cache with IceClean or CleanMyMac
    • Navigate to /System/Library/Filesystems and see if there are 3rd party .fs files such as ufsd_NTFS.fs, the date timestamps should give you an indication
    • Try again :)

Share This Page