Issue WPS Transaction Failure and Reaver Version Change

Discussion in 'Xiaopan Support' started by njyk633, 28 Oct 2012.

  1. njyk633

    njyk633 Member

    26 Oct 2012
    Likes Received:

    I have a problem with Xiaopan 0.4.3b
    I'm running it on my laptop using boot from USB.
    Internal wireless card is Atheros AR9285.

    When I try to access to any of large amount of APs around me (about 20 different APs with strong signal), reaver constantly shows the same error:
    WPS Transaction Failed (code: 0x02)
    And trying the same pin over and over again.

    I tried to search for solution of this problem and the only thing that I've found is to use a lower version of reaver. There is Reaver v 1.4 preinstalled in Xiaopan 0.4.3b, so I wanted to install Reaver v 1.3 instead (from . But unfortunately, when i try to enter ./configure command in src dir of the unpacked reaver-1.3.tar.gz , it shows me an error that "there is no C compiller installed in the system" or something like this (I can paste here the exact error contents if needed).

    So, the first question is:
    1. How to install Reaver v 1.3 on Xiaopan 0.4.3b?

    Also, in case if there is a problem in my wireless adapter, not in the software, I have 2more questions:

    2. If I buy a new wireless usb adapter, wich one should I chose to have guaranteed positive result (name a few models please)?

    3. If I plug in a wireless usb adapter when running Xiaopan 0.4.3b, would it be instantly mounted and available for selection in reaver? If not, what commands should I type in terminal (or gui menus) to mount it?

    Thank you in advance.
  2. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member VIP Admin

    18 May 2012
    Likes Received:
    1) Xiaopan 0.3.8 came with Reaver 1.3. You might be able to remaster an ISO to include the tcz or tce files required into 0.4.3.
    2) AWUS036NHA / AWUS036H or cheap RTL8187L devices

    Listed on Google Code
    • ath9k
    • rtl8187
    • carl19170
    • ipw2000
    • rt2800pci
    • rt73usb
    Source: Login or Signup to view links / downloads

    3) It should be mounted automatically. But you might have to select it if you are using virtualisation. Because it will most likely be in use with your host computer.

    Remember PCI and other internal cards do not work with virtualisation. You must run it live.
  • About Us

    We are a community mixed with professionals and beginners with an interest in wireless security, auditing and pentesting. Feel free to check out and upload resources.

    You can also find us on: Twitter and Facebook

  • Donate to Us

    Did you find our forums useful? Feel free to donate Bitcoin to us using the form below. Those who donate the equivlent of $10 USD or more will be upgraded to VIP membership. Don't have Bitcoin? Use your credit card to GO VIP here. Don't want to fork out some coin? There are other ways to GO VIP. Bitcoin: 1LMTGSoTyJWXuy2mQkHfgMzD7ez74x1Z8K