Issue Xiaopan OS Cannot Detect My Ralink 3070

Discussion in 'Xiaopan Support' started by Mr. Penguin, 29 May 2012.

  1. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    18 May 2012
    Likes Received:
    Our First Submitted Support Survey

    1. What is the issue?
    No detect my usb wireless adapter.

    2. What are you trying to achieve?
    Hack WPS with Reaver and Inflator

    3. What is your wireless device model? (e.g. rtl8187L, AR9287)
    Ralink 3070

    4. Is this a USB or internal device?
    No Response

    5. How are you using it?
    I am using Xiaopan as a LiveCD

    6. What version of Xiaopan are you using?
    Beini 1.2.2

    7. Have you tried other versions of Beini and Xiaopan and the issue still exists?
    Xiaopan 0.4
    Xiaopan 0.4.1
    Xiaopan 0.4.2
    Beini 1.2.1
    Beini 1.2.3
    Beini 1.2.4
    Beini 1.2.5

    8. Is there anything else you would like to tell us? Your issue will be posted and responded to here:
    I am new to this and I would appreciate if you can create a new version that works with my Wireless card. Thank you.

    9. What is your username (case sensitive please) on Xiaopan OS Forums? If you do not have an account please create one so you can fill out this form.
  2. Mr. Penguin

    Mr. Penguin Administrator
    Staff Member Admin Moderator VIP

    18 May 2012
    Likes Received:
    You have tried all those versions and not one can detect your wireless device? I am so sorry to hear that.

    If you are not using AR9271 chips, please delete:


    or any other atheros driver that maybe used.

    These will cause some problems with some cards, after that please add:


    in Beini or Xiaopan OS for supporting RT3070 chips.

    You will have to use UltraISO to edit the .tce (Beini) or .cde (Xiaopan) folder

    Alternatively you can try this edited version of Beini (no reaver or inflator) that is compatible with your card: 2Shared (ibeini_122___rt2x00_2634.iso)

    Other Downloads & Useful Links
    sqlite3.tcz (you may or may not need to replace this file in tce or cde. Try doing and not doing so)

    Then you will also have to install Reaver and Inflator by uploading the other two files in the tce or cde folder you see below. Please let us know how you go. So we can mark this issue as resolved.

    See here how to edit the ISO and create a bootable USB

    Keep in mind that the RT3070 is reported to have issues with Reaver: Supported Wireless Drivers

    User in Chat Stated This
    20 minutes ago - chu2012:
    Xiaopan 0.3.8 Works perfectly with my usb adapter RT3070

    Attached Files:

  3. hazz death

    hazz death Well-Known Member
    Dev Team VIP

    19 Jun 2012
    Likes Received:
    what is this?
  4. amaal

    amaal Member

    16 Oct 2013
    Likes Received:
    i can choose my usb wifi adaptor before clicking feeding bottle it detects my usb ralink but when i scan for ssid it does nothing i have tried all versions of benini and xiaopan os's even in back track5.
  • About Us

    We are a community mixed with professionals and beginners with an interest in wireless security, auditing and pentesting. Feel free to check out and upload resources.

    You can also find us on: Twitter and Facebook

  • Donate to Us

    Did you find our forums useful? Feel free to donate Bitcoin to us using the form below. Those who donate the equivlent of $10 USD or more will be upgraded to VIP membership. Don't have Bitcoin? Use your credit card to GO VIP here. Don't want to fork out some coin? There are other ways to GO VIP. Bitcoin: 1LMTGSoTyJWXuy2mQkHfgMzD7ez74x1Z8K